Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME configuration system" |
| 2 | SECTION = "x11/gnome" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 3 | HOMEPAGE = "https://projects.gnome.org/gconf/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | LICENSE = "LGPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 6 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 7 | DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 9 | inherit gnomebase gtk-doc gettext gobject-introspection gio-module-cache |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \ |
| 12 | file://remove_plus_from_invalid_characters_list.patch \ |
| 13 | file://unable-connect-dbus.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | file://create_config_directory.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c" |
| 18 | SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c" |
| 19 | |
| 20 | S = "${WORKDIR}/GConf-${PV}" |
| 21 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 22 | EXTRA_OECONF = "--enable-shared --disable-static \ |
| 23 | --disable-orbit --with-openldap=no --disable-gtk" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 24 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}" |
| 26 | # We really don't want Polkit for native |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | PACKAGECONFIG_class-native = "" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | PACKAGECONFIG[polkit] = "--enable-defaults-service,--disable-defaults-service,polkit" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 30 | PACKAGECONFIG[debug] = "--enable-debug=yes, --enable-debug=minimum" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 31 | |
| 32 | do_install_append() { |
| 33 | # this directory need to be created to avoid an Error 256 at gdm launch |
| 34 | install -d ${D}${sysconfdir}/gconf/gconf.xml.system |
| 35 | |
| 36 | # this stuff is unusable |
| 37 | rm -f ${D}${libdir}/GConf/*/*.*a |
| 38 | rm -f ${D}${libdir}/gio/*/*.*a |
| 39 | } |
| 40 | |
| 41 | do_install_append_class-native() { |
| 42 | create_wrapper ${D}/${bindir}/gconftool-2 \ |
| 43 | GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2 |
| 44 | } |
| 45 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 46 | FILES_${PN} += "${libdir}/GConf/* \ |
| 47 | ${libdir}/gio/*/*.so \ |
| 48 | ${datadir}/polkit* \ |
| 49 | ${datadir}/dbus-1/services/*.service \ |
| 50 | ${datadir}/dbus-1/system-services/*.service \ |
| 51 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 52 | FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd" |
| 53 | |
| 54 | BBCLASSEXTEND = "native" |