Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Script-directed dynamic tracing and performance analysis tool for Linux" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://sourceware.org/systemtap/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | |
| 4 | require systemtap_git.inc |
| 5 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | SRC_URI += "file://0001-improve-reproducibility-for-c-compiling.patch" |
| 7 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | DEPENDS = "elfutils" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | |
| 10 | EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \ |
| 11 | --without-nss --without-avahi --without-dyninst \ |
| 12 | --disable-server --disable-grapher --enable-prologues \ |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 13 | --with-python3 --without-python2-probes \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | ac_cv_prog_have_javac=no \ |
| 15 | ac_cv_prog_have_jar=no " |
| 16 | |
| 17 | STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs" |
| 18 | |
| 19 | EXTRA_OECONF += "${STAP_DOCS} " |
| 20 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | PACKAGECONFIG ??= "translator sqlite monitor python3-probes" |
| 22 | PACKAGECONFIG[translator] = "--enable-translator,--disable-translator,boost,python3-core bash perl" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 23 | PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 24 | PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3" |
| 25 | PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c" |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 26 | PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | inherit autotools gettext pkgconfig distutils3-base systemd |
| 29 | |
| 30 | PACKAGES =+ "${PN}-exporter" |
| 31 | |
| 32 | FILES_${PN}-exporter = "${sysconfdir}/stap-exporter/* \ |
| 33 | ${sysconfdir}/sysconfig/stap-exporter \ |
| 34 | ${systemd_unitdir}/system/stap-exporter.service \ |
| 35 | ${sbindir}/stap-exporter" |
| 36 | |
| 37 | RDEPENDS_${PN}-exporter = "${PN} python3-core python3-netclient" |
| 38 | |
| 39 | SYSTEMD_SERVICE_${PN}-exporter = "stap-exporter.service" |
| 40 | |
| 41 | do_configure_prepend () { |
| 42 | # Improve reproducibility for c++ object files |
| 43 | reltivepath="${@os.path.relpath(d.getVar('STAGING_INCDIR'), d.getVar('S'))}" |
| 44 | sed -i "s:@RELATIVE_STAGING_INCDIR@:$reltivepath:g" ${S}/stringtable.h |
| 45 | } |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 46 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 47 | do_install_append () { |
| 48 | if [ ! -f ${D}${bindir}/stap ]; then |
| 49 | # translator disabled case, need to leave only minimal runtime |
| 50 | rm -rf ${D}${datadir}/${PN} |
| 51 | rm ${D}${libexecdir}/${PN}/stap-env |
| 52 | fi |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 53 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 54 | if [ ${D}${prefix}/lib != `dirname ${D}${systemd_unitdir}` ]; then |
| 55 | # Fix makefile hardcoded path assumptions for systemd (assumes $prefix) |
| 56 | # without usrmerge distro feature enabled |
| 57 | install -d `dirname ${D}${systemd_unitdir}` |
| 58 | mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}` |
| 59 | rmdir ${D}${prefix}/lib --ignore-fail-on-non-empty |
| 60 | fi |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | |
| 62 | # Ensure correct ownership for files copied in |
| 63 | chown root:root ${D}${sysconfdir}/stap-exporter/* -R |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 64 | } |
| 65 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 66 | BBCLASSEXTEND = "nativesdk" |