Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Automated text and program generation tool" |
| 2 | DESCRIPTION = "AutoGen is a tool designed to simplify the creation and\ |
| 3 | maintenance of programs that contain large amounts of repetitious text.\ |
| 4 | It is especially valuable in programs that have several blocks of text\ |
| 5 | that must be kept synchronized." |
| 6 | HOMEPAGE = "http://www.gnu.org/software/autogen/" |
| 7 | SECTION = "devel" |
| 8 | LICENSE = "GPLv3" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 10 | |
| 11 | SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \ |
| 12 | file://increase-timeout-limit.patch \ |
| 13 | file://mk-tpl-config.sh-force-exit-value-to-be-0-in-subproc.patch \ |
| 14 | file://redirect-output-dir.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "385d7c7dfbe60babbee261c054923a53" |
| 18 | SRC_URI[sha256sum] = "7bbdb73b5518baf64c6d3739fb2ecc66d2cccda888ce5ad573abe235ab5d96ba" |
| 19 | |
| 20 | DEPENDS = "guile-native libtool-native libxml2-native" |
| 21 | |
| 22 | inherit autotools texinfo native pkgconfig |
| 23 | |
| 24 | # autogen-native links against libguile which may have been relocated with sstate |
| 25 | # these environment variables ensure there isn't a relocation issue |
| 26 | export GUILE_LOAD_PATH = "${STAGING_DATADIR_NATIVE}/guile/2.0" |
| 27 | export GUILE_LOAD_COMPILED_PATH = "${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache" |
| 28 | |
| 29 | do_install_append () { |
| 30 | create_wrapper ${D}/${bindir}/autogen \ |
| 31 | GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \ |
| 32 | GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache |
| 33 | } |