blob: 3201c6996e8eb1fda6bb0311524e007bed243b39 [file] [log] [blame]
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -05001SUMMARY = "OpenPower Software Management"
2DESCRIPTION = "OpenPower Software Manager provides a set of host software \
3management daemons. It is suitable for use on a wide variety of OpenPower \
4platforms."
5HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt"
6PR = "r1"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
9
10inherit autotools pkgconfig
11inherit obmc-phosphor-dbus-service
12
13DEPENDS += " \
14 autoconf-archive-native \
15 phosphor-dbus-interfaces \
16 phosphor-logging \
17 sdbusplus \
18 "
19
20RDEPENDS_${PN} += " \
21 mtd-utils-ubifs \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
24 sdbusplus \
25 "
26
27DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
28SYSTEMD_SERVICE_${PN} += " \
29 obmc-flash-bios-ubiattach.service \
30 obmc-flash-bios-ubimount@.service \
31 obmc-flash-bios-squashfsmount@.service \
32 "
33
34SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt"
Patrick Williams6ce5e992017-05-24 14:00:03 -050035SRCREV = "dd961b6ca475dbbf74826333452a2eae9d47837c"
Adriana Kobylakf20b3aa2017-04-28 16:05:39 -050036
37S = "${WORKDIR}/git"