Adriana Kobylak | f20b3aa | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 1 | SUMMARY = "OpenPower Software Management" |
| 2 | DESCRIPTION = "OpenPower Software Manager provides a set of host software \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenPower \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/openpower-pnor-code-mgmt" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | inherit obmc-phosphor-dbus-service |
| 12 | |
| 13 | DEPENDS += " \ |
| 14 | autoconf-archive-native \ |
| 15 | phosphor-dbus-interfaces \ |
| 16 | phosphor-logging \ |
| 17 | sdbusplus \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS_${PN} += " \ |
| 21 | mtd-utils-ubifs \ |
| 22 | phosphor-dbus-interfaces \ |
| 23 | phosphor-logging \ |
| 24 | sdbusplus \ |
| 25 | " |
| 26 | |
| 27 | DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service" |
| 28 | SYSTEMD_SERVICE_${PN} += " \ |
| 29 | obmc-flash-bios-ubiattach.service \ |
| 30 | obmc-flash-bios-ubimount@.service \ |
| 31 | obmc-flash-bios-squashfsmount@.service \ |
| 32 | " |
| 33 | |
| 34 | SRC_URI += "git://github.com/openbmc/openpower-pnor-code-mgmt" |
Patrick Williams | 6ce5e99 | 2017-05-24 14:00:03 -0500 | [diff] [blame] | 35 | SRCREV = "dd961b6ca475dbbf74826333452a2eae9d47837c" |
Adriana Kobylak | f20b3aa | 2017-04-28 16:05:39 -0500 | [diff] [blame] | 36 | |
| 37 | S = "${WORKDIR}/git" |