Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "GNOME library for reading .desktop files" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPLv2 & LGPLv2" |
| 4 | LIC_FILES_CHKSUM = " \ |
| 5 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 7 | " |
| 8 | |
| 9 | GNOMEBASEBUILDCLASS = "meson" |
| 10 | |
| 11 | inherit gnomebase itstool pkgconfig upstream-version-is-even gobject-introspection features_check gtk-doc |
| 12 | |
| 13 | REQUIRED_DISTRO_FEATURES = "x11" |
| 14 | # gobject-introspection is mandatory and cannot be configured |
| 15 | REQUIRED_DISTRO_FEATURES += "gobject-introspection-data" |
| 16 | |
| 17 | GIR_MESON_OPTION = "" |
| 18 | |
| 19 | SRC_URI[archive.sha256sum] = "34329eefdacad2332a6adbae538c8da6e52235c7775a908b7c32040a0753ec6a" |
| 20 | SRC_URI += " \ |
| 21 | file://gnome-desktop-thumbnail-don-t-assume-time_t-is-long.patch \ |
| 22 | file://0001-meson.build-Disable-libseccomp-for-all-archs.patch \ |
| 23 | " |
| 24 | |
| 25 | DEPENDS += "gsettings-desktop-schemas virtual/libx11 gtk+3 startup-notification xkeyboard-config iso-codes udev" |
| 26 | |
| 27 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 28 | EXTRA_OEMESON = "-Ddesktop_docs=false" |
| 29 | |
| 30 | PACKAGES =+ "libgnome-desktop" |
| 31 | RDEPENDS:${PN} += "libgnome-desktop" |
| 32 | FILES:libgnome-desktop = " \ |
| 33 | ${libdir}/lib*${SOLIBS} \ |
| 34 | ${datadir}/libgnome-desktop*/pnp.ids \ |
| 35 | ${datadir}/gnome/*xml \ |
| 36 | " |
| 37 | |
| 38 | RRECOMMENDS:libgnome-desktop += "gsettings-desktop-schemas" |