Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | DESCRPTION = "ansi2html - Convert text with ANSI color codes to HTML or to LaTeX" |
| 2 | HOMEPAGE = "https://github.com/ralphbean/ansi2html" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3000208d539ec061b899bce1d9ce9404" |
| 4 | LICENSE = "GPLv3" |
| 5 | |
| 6 | PYPI_PACKAGE = "ansi2html" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "69316be8c68ac91c5582d397c2890e69c993cc7cda52062ac7e45fcb660d8edc" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
| 12 | DEPENDS += " \ |
| 13 | ${PYTHON_PN}-setuptools-scm-native \ |
| 14 | ${PYTHON_PN}-toml-native \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS:${PN} = " \ |
| 18 | ${PYTHON_PN}-six \ |
| 19 | ${PYTHON_PN}-compression \ |
| 20 | " |
| 21 | |
| 22 | do_compile:prepend() { |
| 23 | echo "from setuptools import setup" > ${S}/setup.py |
| 24 | echo "setup()" >> ${S}/setup.py |
| 25 | } |