Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "TCTI module for use with TSS2 libraries in UEFI environment" |
| 2 | SECTION = "security/tpm" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | DEPENDS = "libtss2-dev gnu-efi-native gnu-efi pkgconfig autoconf-archive-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | |
| 7 | SRC_URI = "git://github.com/tpm2-software/tpm2-tcti-uefi.git \ |
| 8 | file://configure_oe_fixup.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 9 | file://0001-configure.ac-stop-inserting-host-directories-into-co.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | SRCREV = "7baf1eebfeb56a896bdd5d677fb24377d619eb9d" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit autotools pkgconfig |
| 16 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 17 | EFIDIR ?= "/EFI/BOOT" |
| 18 | |
| 19 | do_compile_append() { |
| 20 | oe_runmake example |
| 21 | } |
| 22 | |
| 23 | do_install_append() { |
| 24 | install -d "${D}${EFIDIR}" |
| 25 | install -m 0755 "${B}"/example/*.efi "${D}${EFIDIR}" |
| 26 | } |
| 27 | |
| 28 | EFI_ARCH_x86 = "ia32" |
| 29 | EFI_ARCH_x86-64 = "x86_64" |
| 30 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 32 | EXTRA_OECONF_append = "\ |
| 33 | --with-efi-includedir=${STAGING_INCDIR}/efi \ |
| 34 | --with-efi-crt0=${STAGING_LIBDIR_NATIVE}/crt0-efi-${EFI_ARCH}.o \ |
| 35 | --with-efi-lds=${STAGING_LIBDIR_NATIVE}/elf_${EFI_ARCH}_efi.lds \ |
| 36 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | RDEPENDS_${PN} = "gnu-efi" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 38 | |
| 39 | FILES_${PN} += "${EFIDIR}" |