Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "7-zip is a commandline utility handling 7z archives." |
| 2 | HOMEPAGE = "http://www.7-zip.org/" |
| 3 | LICENSE = "LGPL-2.1+ & unRAR" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://DOC/copying.txt;md5=4fbd65380cdd255951079008b364516c \ |
| 5 | file://DOC/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de \ |
| 6 | file://DOC/License.txt;md5=879598edf1f54dddb6930d7581357f8b" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 7 | |
| 8 | SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | file://do_not_override_compiler_and_do_not_strip.patch \ |
| 10 | file://CVE-2017-17969.patch \ |
| 11 | file://0001-Fix-narrowing-errors-Wc-11-narrowing.patch \ |
| 12 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 13 | |
| 14 | SRC_URI[md5sum] = "a0128d661cfe7cc8c121e73519c54fbf" |
| 15 | SRC_URI[sha256sum] = "5eb20ac0e2944f6cb9c2d51dd6c4518941c185347d4089ea89087ffdd6e2341f" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/${BPN}_${PV}" |
| 18 | |
| 19 | do_install() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | install -d ${D}${bindir} |
| 21 | install -m 0755 ${S}/bin/* ${D}${bindir} |
| 22 | ln -s 7za ${D}${bindir}/7z |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | } |
| 24 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | BBCLASSEXTEND = "native" |