Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | KBRANCH ?= "v4.14/standard/base" |
| 2 | |
| 3 | require recipes-kernel/linux/linux-yocto.inc |
| 4 | |
| 5 | # board specific branches |
| 6 | KBRANCH_qemuarm ?= "v4.14/standard/arm-versatile-926ejs" |
| 7 | KBRANCH_qemuarm64 ?= "v4.14/standard/qemuarm64" |
| 8 | KBRANCH_qemumips ?= "v4.14/standard/mti-malta32" |
| 9 | KBRANCH_qemuppc ?= "v4.14/standard/qemuppc" |
| 10 | KBRANCH_qemux86 ?= "v4.14/standard/base" |
| 11 | KBRANCH_qemux86-64 ?= "v4.14/standard/base" |
| 12 | KBRANCH_qemumips64 ?= "v4.14/standard/mti-malta64" |
| 13 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 14 | SRCREV_machine_qemuarm ?= "363723ef50c06df54e146c8fe78faa962e96a8c8" |
| 15 | SRCREV_machine_qemuarm64 ?= "798d15552a4d5d9355a300290ed6bf72106b7e96" |
| 16 | SRCREV_machine_qemumips ?= "6c2433d7c51c3e78b1be2c7d1fbfe840b13d04df" |
| 17 | SRCREV_machine_qemuppc ?= "c03babad17499489b20216576d608c94e7fddc5d" |
| 18 | SRCREV_machine_qemux86 ?= "65d1c849534179bbfa494f77947f8be615e9871a" |
| 19 | SRCREV_machine_qemux86-64 ?= "65d1c849534179bbfa494f77947f8be615e9871a" |
| 20 | SRCREV_machine_qemumips64 ?= "59f70381cbde371e41206b7902390ae78558c310" |
| 21 | SRCREV_machine ?= "65d1c849534179bbfa494f77947f8be615e9871a" |
| 22 | SRCREV_meta ?= "94457657b8d621868672917d1c2631df4a4fadd8" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 23 | |
| 24 | SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \ |
| 25 | git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}" |
| 26 | |
Brad Bishop | d5ae7d9 | 2018-06-14 09:52:03 -0700 | [diff] [blame] | 27 | LINUX_VERSION ?= "4.14.48" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | |
| 29 | DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}" |
| 30 | DEPENDS += "openssl-native util-linux-native" |
| 31 | |
| 32 | PV = "${LINUX_VERSION}+git${SRCPV}" |
| 33 | |
| 34 | KMETA = "kernel-meta" |
| 35 | KCONF_BSP_AUDIT_LEVEL = "2" |
| 36 | |
| 37 | KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb" |
| 38 | |
| 39 | COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64" |
| 40 | |
| 41 | # Functionality flags |
| 42 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc" |
| 43 | KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}" |
| 44 | KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc" |
| 45 | KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc" |
| 46 | KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc" |
| 47 | KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" |