Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require ruby.inc |
| 2 | |
| 3 | SRC_URI += " \ |
| 4 | file://ruby-CVE-2017-9226.patch \ |
| 5 | file://ruby-CVE-2017-9228.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | " |
| 7 | |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 8 | SRC_URI[md5sum] = "20c85b67846d49622ef3b24230803fef" |
| 9 | SRC_URI[sha256sum] = "9828d03852c37c20fa333a0264f2490f07338576734d910ee3fd538c9520846c" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 10 | |
| 11 | # it's unknown to configure script, but then passed to extconf.rb |
| 12 | # maybe it's not really needed as we're hardcoding the result with |
| 13 | # 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch |
| 14 | UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo" |
| 15 | |
| 16 | PACKAGECONFIG ??= "" |
| 17 | PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 18 | |
| 19 | PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind" |
| 20 | PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp" |
| 21 | PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo," |
| 22 | |
| 23 | EXTRA_AUTORECONF += "--exclude=aclocal" |
| 24 | |
| 25 | EXTRA_OECONF = "\ |
| 26 | --disable-versioned-paths \ |
| 27 | --disable-rpath \ |
| 28 | --disable-dtrace \ |
| 29 | --enable-shared \ |
| 30 | --enable-load-relative \ |
| 31 | " |
| 32 | |
| 33 | do_install() { |
| 34 | oe_runmake 'DESTDIR=${D}' install |
| 35 | } |
| 36 | |
| 37 | do_install_append_class-target () { |
| 38 | # Find out rbconfig.rb from .installed.list |
| 39 | rbconfig_rb=`grep rbconfig.rb ${B}/.installed.list` |
| 40 | # Remove build host directories |
| 41 | sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \ |
| 42 | -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \ |
| 43 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 44 | -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 45 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 46 | -e 's:${RECIPE_SYSROOT}::g' \ |
| 47 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \ |
| 48 | ${D}$rbconfig_rb |
| 49 | |
| 50 | # Find out created.rid from .installed.list |
| 51 | created_rid=`grep created.rid ${B}/.installed.list` |
| 52 | # Remove build host directories |
| 53 | sed -i -e 's:${WORKDIR}::g' ${D}$created_rid |
| 54 | |
| 55 | } |
| 56 | |
| 57 | PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc" |
| 58 | |
| 59 | SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library" |
| 60 | RDEPENDS_${PN}-ri-docs = "${PN}" |
| 61 | FILES_${PN}-ri-docs += "${datadir}/ri" |
| 62 | |
| 63 | SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source" |
| 64 | RDEPENDS_${PN}-rdoc = "${PN}" |
| 65 | FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc" |
| 66 | |
| 67 | FILES_${PN} += "${datadir}/rubygems" |
| 68 | |
| 69 | BBCLASSEXTEND = "native" |