Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/firehol/netdata/" |
| 2 | SUMMARY = "Real-time performance monitoring" |
| 3 | LICENSE = "GPLv3" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 5 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | SRC_URI = "git://github.com/firehol/netdata.git;protocol=https \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 7 | file://0002-Makefiles-does-not-build-contrib-dir.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | " |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 9 | SRCREV = "588ce5a7b18999dfa66698cd3a2f005f7a3c31cf" |
| 10 | PV = "1.17.0" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 11 | |
| 12 | # patch to disable timeout because timeout are not available with actual version |
| 13 | # of core-utils |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 14 | SRC_URI += "file://0001-Correct-timeout-issue.patch" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 15 | |
| 16 | # default netdata.conf for netdata configuration |
| 17 | SRC_URI += "file://netdata.conf" |
| 18 | |
| 19 | # file for providing systemd service support |
| 20 | SRC_URI += "file://netdata.service" |
| 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 24 | DEPENDS += "zlib util-linux" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 26 | inherit pkgconfig autotools-brokensep useradd systemd |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 28 | LIBS_toolchain-clang_x86 = "-latomic" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | LIBS_riscv64 = "-latomic" |
| 30 | LIBS_riscv32 = "-latomic" |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 31 | export LIBS |
| 32 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 33 | #systemd |
| 34 | SYSTEMD_PACKAGES = "${PN}" |
| 35 | SYSTEMD_SERVICE_${PN} = "netdata.service" |
| 36 | SYSTEMD_AUTO_ENABLE_${PN} = "enable" |
| 37 | |
| 38 | #User specific |
| 39 | USERADD_PACKAGES = "${PN}" |
| 40 | GROUPADD_PARAM_${PN} = "--system netdata" |
| 41 | |
| 42 | do_install_append() { |
| 43 | #set S UID for plugins |
| 44 | chmod 4755 ${D}${libexecdir}/netdata/plugins.d/apps.plugin |
| 45 | |
| 46 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 47 | # Install systemd unit files |
| 48 | install -d ${D}${systemd_unitdir}/system |
| 49 | install -m 0644 ${WORKDIR}/netdata.service ${D}${systemd_unitdir}/system |
| 50 | sed -i -e 's,@@datadir,${datadir_native},g' ${D}${systemd_unitdir}/system/netdata.service |
| 51 | fi |
| 52 | |
| 53 | # Install default netdata.conf |
| 54 | install -d ${D}${sysconfdir}/netdata |
| 55 | install -m 0644 ${WORKDIR}/netdata.conf ${D}${sysconfdir}/netdata/ |
| 56 | sed -i -e 's,@@sysconfdir,${sysconfdir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 57 | sed -i -e 's,@@libdir,${libexecdir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 58 | sed -i -e 's,@@datadir,${datadir},g' ${D}${sysconfdir}/netdata/netdata.conf |
| 59 | } |
| 60 | |
| 61 | FILES_${PN}-dbg += "${libexecdir}/netdata/plugins.d/.debug" |
| 62 | RDEPENDS_${PN} = "bash zlib" |