Matt Spinler | 5944191 | 2020-03-24 19:36:10 +0000 | [diff] [blame] | 1 | PACKAGECONFIG_append_witherspoon-tacoma = " openpower-pels" |
Adriana Kobylak | dd62594 | 2021-03-25 16:44:49 +0000 | [diff] [blame] | 2 | PACKAGECONFIG_append_p10bmc = " openpower-pels" |
Matt Spinler | 07dedc2 | 2020-10-29 15:27:26 -0500 | [diff] [blame] | 3 | |
| 4 | FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:" |
| 5 | |
| 6 | SRC_URI_append_p10bmc = " file://ibm,rainier-2u_dev_callouts.json" |
| 7 | SRC_URI_append_p10bmc = " file://ibm,rainier-4u_dev_callouts.json" |
| 8 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-logging/pels/ibm,rainier-2u_dev_callouts.json" |
| 9 | FILES_${PN}_append_p10bmc = " ${datadir}/phosphor-logging/pels/ibm,rainier-4u_dev_callouts.json" |
| 10 | |
Jayanth Othayoth | fa28a72 | 2021-06-21 07:26:05 -0500 | [diff] [blame] | 11 | #Enable phal feature, if available. |
| 12 | PACKAGECONFIG_append = " ${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" |
| 13 | PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata libekb pdbg" |
| 14 | |
Matt Spinler | 07dedc2 | 2020-10-29 15:27:26 -0500 | [diff] [blame] | 15 | do_install_append_p10bmc() { |
| 16 | install -d ${D}/${datadir}/phosphor-logging/pels |
| 17 | install -m 0644 ${WORKDIR}/ibm,rainier-2u_dev_callouts.json ${D}/${datadir}/phosphor-logging/pels/ibm,rainier-2u_dev_callouts.json |
| 18 | install -m 0644 ${WORKDIR}/ibm,rainier-4u_dev_callouts.json ${D}/${datadir}/phosphor-logging/pels/ibm,rainier-4u_dev_callouts.json |
Andrew Geissler | 8516182 | 2021-03-29 11:59:01 -0500 | [diff] [blame] | 19 | ln -s ./ibm,rainier-4u_dev_callouts.json ${D}/${datadir}/phosphor-logging/pels/ibm,rainier-1s4u_dev_callouts.json |
Matt Spinler | 07dedc2 | 2020-10-29 15:27:26 -0500 | [diff] [blame] | 20 | } |