Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DISABLE_STATIC = "" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 2 | SUMMARY = "Linux-PAM (Pluggable Authentication Modules)" |
| 3 | DESCRIPTION = "Linux-PAM (Pluggable Authentication Modules for Linux), a flexible mechanism for authenticating users" |
| 4 | HOMEPAGE = "https://fedorahosted.org/linux-pam/" |
| 5 | BUGTRACKER = "https://fedorahosted.org/linux-pam/newticket" |
| 6 | SECTION = "base" |
| 7 | # PAM is dual licensed under GPL and BSD. |
| 8 | # /etc/pam.d comes from Debian libpam-runtime in 2009-11 (at that time |
| 9 | # libpam-runtime-1.0.1 is GPLv2+), by openembedded |
| 10 | LICENSE = "GPLv2+ | BSD" |
Brad Bishop | f8caae3 | 2019-03-25 13:13:56 -0400 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=7eb5c1bf854e8881005d673599ee74d3 \ |
| 12 | file://libpamc/License;md5=a4da476a14c093fdc73be3c3c9ba8fb3 \ |
| 13 | " |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 15 | SRC_URI = "https://github.com/linux-pam/linux-pam/releases/download/v${PV}/Linux-PAM-${PV}.tar.xz \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 16 | file://99_pam \ |
| 17 | file://pam.d/common-account \ |
| 18 | file://pam.d/common-auth \ |
| 19 | file://pam.d/common-password \ |
| 20 | file://pam.d/common-session \ |
| 21 | file://pam.d/common-session-noninteractive \ |
| 22 | file://pam.d/other \ |
| 23 | file://libpam-xtests.patch \ |
Andrew Geissler | 87ddd3e | 2021-01-28 18:27:13 -0600 | [diff] [blame] | 24 | file://pam-security-abstract-securetty-handling.patch \ |
| 25 | file://pam-unix-nullok-secure.patch \ |
| 26 | file://crypt_configure.patch \ |
| 27 | " |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 28 | |
Andrew Geissler | 87ddd3e | 2021-01-28 18:27:13 -0600 | [diff] [blame] | 29 | SRC_URI[md5sum] = "558ff53b0fc0563ca97f79e911822165" |
| 30 | SRC_URI[sha256sum] = "eff47a4ecd833fbf18de9686632a70ee8d0794b79aecb217ebd0ce11db4cd0db" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 31 | |
Andrew Geissler | 706d5aa | 2021-02-12 15:55:30 -0600 | [diff] [blame] | 32 | SRC_URI_append_libc-musl = " file://0001-Add-support-for-defining-missing-funcitonality.patch \ |
| 33 | file://include_paths_header.patch \ |
| 34 | " |
| 35 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | DEPENDS = "bison-native flex flex-native cracklib libxml2-native virtual/crypt" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 37 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | EXTRA_OECONF = "--includedir=${includedir}/security \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 39 | --libdir=${base_libdir} \ |
| 40 | --disable-nis \ |
| 41 | --disable-regenerate-docu \ |
| 42 | --disable-prelude" |
| 43 | |
| 44 | CFLAGS_append = " -fPIC " |
| 45 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 46 | S = "${WORKDIR}/Linux-PAM-${PV}" |
| 47 | |
Andrew Geissler | 87ddd3e | 2021-01-28 18:27:13 -0600 | [diff] [blame] | 48 | inherit autotools gettext pkgconfig |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 49 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | PACKAGECONFIG ??= "" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 51 | PACKAGECONFIG[audit] = "--enable-audit,--disable-audit,audit," |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 52 | PACKAGECONFIG[userdb] = "--enable-db=db,--enable-db=no,db," |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 53 | |
| 54 | PACKAGES += "${PN}-runtime ${PN}-xtests" |
| 55 | FILES_${PN} = "${base_libdir}/lib*${SOLIBS}" |
| 56 | FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libdir}/lib*${SOLIBSDEV}" |
Andrew Geissler | 87ddd3e | 2021-01-28 18:27:13 -0600 | [diff] [blame] | 57 | FILES_${PN}-runtime = "${sysconfdir}" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 58 | FILES_${PN}-xtests = "${datadir}/Linux-PAM/xtests" |
| 59 | |
| 60 | PACKAGES_DYNAMIC += "^${MLPREFIX}pam-plugin-.*" |
| 61 | |
| 62 | def get_multilib_bit(d): |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 63 | baselib = d.getVar('baselib') or '' |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 64 | return baselib.replace('lib', '') |
| 65 | |
| 66 | libpam_suffix = "suffix${@get_multilib_bit(d)}" |
| 67 | |
| 68 | RPROVIDES_${PN} += "${PN}-${libpam_suffix}" |
| 69 | RPROVIDES_${PN}-runtime += "${PN}-runtime-${libpam_suffix}" |
| 70 | |
| 71 | RDEPENDS_${PN}-runtime = "${PN}-${libpam_suffix} \ |
| 72 | ${MLPREFIX}pam-plugin-deny-${libpam_suffix} \ |
| 73 | ${MLPREFIX}pam-plugin-permit-${libpam_suffix} \ |
| 74 | ${MLPREFIX}pam-plugin-warn-${libpam_suffix} \ |
| 75 | ${MLPREFIX}pam-plugin-unix-${libpam_suffix} \ |
| 76 | " |
| 77 | RDEPENDS_${PN}-xtests = "${PN}-${libpam_suffix} \ |
| 78 | ${MLPREFIX}pam-plugin-access-${libpam_suffix} \ |
| 79 | ${MLPREFIX}pam-plugin-debug-${libpam_suffix} \ |
Andrew Geissler | 87ddd3e | 2021-01-28 18:27:13 -0600 | [diff] [blame] | 80 | ${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 81 | ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \ |
| 82 | ${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \ |
| 83 | ${MLPREFIX}pam-plugin-time-${libpam_suffix} \ |
Andrew Geissler | 87ddd3e | 2021-01-28 18:27:13 -0600 | [diff] [blame] | 84 | coreutils" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 85 | |
| 86 | # FIXME: Native suffix breaks here, disable it for now |
| 87 | RRECOMMENDS_${PN} = "${PN}-runtime-${libpam_suffix}" |
| 88 | RRECOMMENDS_${PN}_class-native = "" |
| 89 | |
| 90 | python populate_packages_prepend () { |
| 91 | def pam_plugin_append_file(pn, dir, file): |
| 92 | nf = os.path.join(dir, file) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 93 | of = d.getVar('FILES_' + pn) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 94 | if of: |
| 95 | nf = of + " " + nf |
| 96 | d.setVar('FILES_' + pn, nf) |
| 97 | |
| 98 | def pam_plugin_hook(file, pkg, pattern, format, basename): |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 99 | pn = d.getVar('PN') |
| 100 | libpam_suffix = d.getVar('libpam_suffix') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 101 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 102 | rdeps = d.getVar('RDEPENDS_' + pkg) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 103 | if rdeps: |
| 104 | rdeps = rdeps + " " + pn + "-" + libpam_suffix |
| 105 | else: |
| 106 | rdeps = pn + "-" + libpam_suffix |
| 107 | d.setVar('RDEPENDS_' + pkg, rdeps) |
| 108 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 109 | provides = d.getVar('RPROVIDES_' + pkg) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 110 | if provides: |
| 111 | provides = provides + " " + pkg + "-" + libpam_suffix |
| 112 | else: |
| 113 | provides = pkg + "-" + libpam_suffix |
| 114 | d.setVar('RPROVIDES_' + pkg, provides) |
| 115 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 116 | mlprefix = d.getVar('MLPREFIX') or '' |
| 117 | dvar = d.expand('${WORKDIR}/package') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 118 | pam_libdir = d.expand('${base_libdir}/security') |
| 119 | pam_sbindir = d.expand('${sbindir}') |
| 120 | pam_filterdir = d.expand('${base_libdir}/security/pam_filter') |
| 121 | pam_pkgname = mlprefix + 'pam-plugin%s' |
| 122 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 123 | do_split_packages(d, pam_libdir, r'^pam(.*)\.so$', pam_pkgname, |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 124 | 'PAM plugin for %s', hook=pam_plugin_hook, extra_depends='') |
| 125 | pam_plugin_append_file('%spam-plugin-unix' % mlprefix, pam_sbindir, 'unix_chkpwd') |
| 126 | pam_plugin_append_file('%spam-plugin-unix' % mlprefix, pam_sbindir, 'unix_update') |
| 127 | pam_plugin_append_file('%spam-plugin-tally' % mlprefix, pam_sbindir, 'pam_tally') |
| 128 | pam_plugin_append_file('%spam-plugin-tally2' % mlprefix, pam_sbindir, 'pam_tally2') |
| 129 | pam_plugin_append_file('%spam-plugin-timestamp' % mlprefix, pam_sbindir, 'pam_timestamp_check') |
| 130 | pam_plugin_append_file('%spam-plugin-mkhomedir' % mlprefix, pam_sbindir, 'mkhomedir_helper') |
| 131 | pam_plugin_append_file('%spam-plugin-console' % mlprefix, pam_sbindir, 'pam_console_apply') |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 132 | do_split_packages(d, pam_filterdir, r'^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 133 | } |
| 134 | |
| 135 | do_install() { |
| 136 | autotools_do_install |
| 137 | |
| 138 | # don't install /var/run when populating rootfs. Do it through volatile |
| 139 | rm -rf ${D}${localstatedir} |
| 140 | install -d ${D}${sysconfdir}/default/volatiles |
| 141 | install -m 0644 ${WORKDIR}/99_pam ${D}${sysconfdir}/default/volatiles |
| 142 | |
| 143 | install -d ${D}${sysconfdir}/pam.d/ |
| 144 | install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/ |
| 145 | |
| 146 | # The lsb requires unix_chkpwd has setuid permission |
| 147 | chmod 4755 ${D}${sbindir}/unix_chkpwd |
| 148 | |
| 149 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 150 | echo "session optional pam_systemd.so" >> ${D}${sysconfdir}/pam.d/common-session |
| 151 | fi |
| 152 | } |
| 153 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 154 | inherit features_check |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 155 | REQUIRED_DISTRO_FEATURES = "pam" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 156 | |
| 157 | BBCLASSEXTEND = "nativesdk native" |
| 158 | |
| 159 | CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session" |
| 160 | CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-auth" |
| 161 | CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-password" |
| 162 | CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-session-noninteractive" |
| 163 | CONFFILES_${PN}-runtime += "${sysconfdir}/pam.d/common-account" |
| 164 | CONFFILES_${PN}-runtime += "${sysconfdir}/security/limits.conf" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 165 | |
| 166 | UPSTREAM_CHECK_URI = "https://github.com/linux-pam/linux-pam/releases" |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 167 | |
| 168 | CVE_PRODUCT = "linux-pam" |