blob: 21dee2b113fc101e38417df4e5d804d61cfd9fa3 [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001SUMMARY = "CRIU"
2DESCRIPTION = "Checkpoint/Restore In Userspace, or CRIU, is a software tool for \
3Linux operating system. Using this tool, you can freeze a running application \
4(or part of it) and checkpoint it to a hard drive as a collection of files. \
5You can then use the files to restore and run the application from the point \
6it was frozen at. The distinctive feature of the CRIU project is that it is \
7mainly implemented in user space"
8HOMEPAGE = "http://criu.org"
9SECTION = "console/tools"
10LICENSE = "GPLv2"
11
12EXCLUDE_FROM_WORLD = "1"
13
Patrick Williamse69d2352017-02-23 20:56:04 -060014LIC_FILES_CHKSUM = "file://COPYING;md5=412de458544c1cb6a2b512cd399286e2"
Patrick Williamsd849ec72016-08-17 14:59:38 -050015
Patrick Williamse69d2352017-02-23 20:56:04 -060016SRCREV = "c031417255f6a5c4409d15ff0b36af5f6e90c559"
Patrick Williamsd849ec72016-08-17 14:59:38 -050017PR = "r0"
Patrick Williamse69d2352017-02-23 20:56:04 -060018PV = "2.5+git${SRCPV}"
Patrick Williamsd849ec72016-08-17 14:59:38 -050019
20SRC_URI = "git://github.com/xemul/criu.git;protocol=git \
Patrick Williamse69d2352017-02-23 20:56:04 -060021 file://0001-criu-Fix-toolchain-hardcode.patch \
22 file://0002-criu-Skip-documentation-install.patch \
23 file://0001-criu-Change-libraries-install-directory.patch \
24 ${@bb.utils.contains('PACKAGECONFIG', 'selinux', '', 'file://disable-selinux.patch', d)} \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025 file://lib-Makefile-overwrite-install-lib-to-allow-multiarc.patch \
Patrick Williamse69d2352017-02-23 20:56:04 -060026 "
Patrick Williamsd849ec72016-08-17 14:59:38 -050027
28COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux"
29
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030DEPENDS += "libnl libcap protobuf-c-native protobuf-c util-linux-native"
Patrick Williamsd849ec72016-08-17 14:59:38 -050031
32S = "${WORKDIR}/git"
33
34#
35# CRIU just can be built on ARMv7 and ARMv6, so the Makefile check
36# if the ARCH is ARMv7 or ARMv6.
37# ARM BSPs need set CRIU_BUILD_ARCH variable for building CRIU.
38#
Patrick Williamse69d2352017-02-23 20:56:04 -060039EXTRA_OEMAKE_arm += "ARCH=arm UNAME-M=${CRIU_BUILD_ARCH} WERROR=0"
40EXTRA_OEMAKE_x86-64 += "ARCH=x86 WERROR=0"
41EXTRA_OEMAKE_aarch64 += "ARCH=arm64 WERROR=0"
Patrick Williamsd849ec72016-08-17 14:59:38 -050042
43EXTRA_OEMAKE_append += "SBINDIR=${sbindir} LIBDIR=${libdir} INCLUDEDIR=${includedir} PIEGEN=no"
44EXTRA_OEMAKE_append += "LOGROTATEDIR=${sysconfdir} SYSTEMDUNITDIR=${systemd_unitdir}"
45
Patrick Williamse69d2352017-02-23 20:56:04 -060046CFLAGS += "-D__USE_GNU -D_GNU_SOURCE "
47
48CFLAGS += " -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3"
Patrick Williamsd849ec72016-08-17 14:59:38 -050049
50# overide LDFLAGS to allow criu to build without: "x86_64-poky-linux-ld: unrecognized option '-Wl,-O1'"
51export LDFLAGS=""
52
53export BUILD_SYS
54export HOST_SYS
55
56inherit setuptools
57
Patrick Williamse69d2352017-02-23 20:56:04 -060058PACKAGECONFIG ??= ""
59PACKAGECONFIG[selinux] = ",,libselinux"
60
Patrick Williamsd849ec72016-08-17 14:59:38 -050061do_compile_prepend() {
Patrick Williamse69d2352017-02-23 20:56:04 -060062 rm -rf ${S}/images/google/protobuf/descriptor.proto
63 ln -s ${PKG_CONFIG_SYSROOT_DIR}/usr/include/google/protobuf/descriptor.proto ${S}/images/google/protobuf/descriptor.proto
Patrick Williamsd849ec72016-08-17 14:59:38 -050064}
65
66do_compile () {
67 oe_runmake
68}
69
70do_install () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050071 export INSTALL_LIB="${libdir}/${PYTHON_DIR}/site-packages"
Patrick Williamsd849ec72016-08-17 14:59:38 -050072 oe_runmake PREFIX=${exec_prefix} LIBDIR=${libdir} DESTDIR="${D}" install
73}
74
75FILES_${PN} += "${systemd_unitdir}/ \
76 ${libdir}/python2.7/site-packages/ \
77 ${libdir}/pycriu/ \
78 ${libdir}/crit-0.0.1-py2.7.egg-info \
79 "