Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | include runc.inc |
| 2 | |
| 3 | SRCREV = "75f8da7c889acc4509a0cf6f0d3a8f9584778375" |
| 4 | SRC_URI = "git://github.com/opencontainers/runc;branch=master \ |
| 5 | " |
| 6 | RUNC_VERSION = "1.0.0-rc3" |
| 7 | PROVIDES += "virtual/runc" |
| 8 | RPROVIDES_${PN} = "virtual/runc" |
| 9 | |
| 10 | do_compile_prepend() { |
| 11 | # Go looks in a src directory under any directory in GOPATH but |
| 12 | # runc-opencontainers uses 'vendor' instead of 'vendor/src'. We can fix |
| 13 | # this with a symlink. |
| 14 | ln -sfn . "${S}/vendor/src" |
| 15 | } |