Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Startup script for the Weston Wayland compositor" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690" |
| 4 | |
| 5 | SRC_URI = "file://init" |
| 6 | |
| 7 | S = "${WORKDIR}" |
| 8 | |
| 9 | do_install() { |
| 10 | install -d ${D}/${sysconfdir}/init.d |
| 11 | install -m755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston |
| 12 | } |
| 13 | |
| 14 | inherit allarch update-rc.d |
| 15 | |
| 16 | RDEPENDS_${PN} = "weston kbd" |
| 17 | |
| 18 | INITSCRIPT_NAME = "weston" |
| 19 | INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ." |