Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Multipurpose relay for bidirectional data transfer" |
| 2 | DESCRIPTION = "Socat is a relay for bidirectional data \ |
| 3 | transfer between two independent data channels." |
| 4 | HOMEPAGE = "http://www.dest-unreach.org/socat/" |
| 5 | |
| 6 | SECTION = "console/network" |
| 7 | |
| 8 | DEPENDS = "openssl readline" |
| 9 | |
| 10 | LICENSE = "GPL-2.0+-with-OpenSSL-exception" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 12 | file://README;beginline=257;endline=287;md5=338c05eadd013872abb1d6e198e10a3f" |
| 13 | |
| 14 | |
| 15 | SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \ |
| 16 | file://Makefile.in-fix-for-parallel-build.patch \ |
| 17 | file://0001-define-NETDB_INTERNAL-to-1-if-not-available.patch \ |
| 18 | file://0001-Access-c_ispeed-and-c_ospeed-via-APIs.patch \ |
| 19 | " |
| 20 | |
| 21 | SRC_URI[md5sum] = "607a24c15bd2cb54e9328bfbbd3a1ae9" |
| 22 | SRC_URI[sha256sum] = "e3561f808739383eb10fada1e5d4f26883f0311b34fd0af7837d0c95ef379251" |
| 23 | |
| 24 | inherit autotools |
| 25 | |
| 26 | EXTRA_AUTORECONF += "--exclude=autoheader" |
| 27 | |
| 28 | EXTRA_OECONF += "ac_cv_have_z_modifier=yes \ |
| 29 | ac_cv_header_bsd_libutil_h=no \ |
| 30 | " |
| 31 | |
| 32 | PACKAGECONFIG_class-target ??= "tcp-wrappers" |
| 33 | PACKAGECONFIG ??= "" |
| 34 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 35 | |
| 36 | do_install_prepend () { |
| 37 | mkdir -p ${D}${bindir} |
| 38 | install -d ${D}${bindir} ${D}${mandir}/man1 |
| 39 | } |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |