Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "A GNU program for formatting C code" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/indent/" |
| 3 | SECTION = "Applications/Text" |
| 4 | DESCRIPTION = "Indent is a GNU program for beautifying C code, so that \ |
| 5 | it is easier to read. Indent can also convert from one C writing style \ |
| 6 | to a different one. Indent understands correct C syntax and tries to handle \ |
| 7 | incorrect C syntax. \ |
| 8 | Install the indent package if you are developing applications in C and \ |
| 9 | you want a program to format your code." |
| 10 | LICENSE = "GPLv3" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 12 | DEPENDS = "virtual/gettext" |
| 13 | |
| 14 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \ |
| 15 | file://0001-src-indent.c-correct-the-check-for-locale.h.patch \ |
| 16 | file://0001-Makefile.am-remove-regression-dir.patch \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "4764b6ac98f6654a35da117b8e5e8e14" |
| 19 | SRC_URI[sha256sum] = "e77d68c0211515459b8812118d606812e300097cfac0b4e9fb3472664263bb8b" |
| 20 | |
| 21 | inherit autotools gettext |
| 22 | |
| 23 | CFLAGS_class-native += " -Wno-error=unused-value" |
| 24 | |
| 25 | FILES_${PN}-doc += "/usr/doc/indent/indent.html" |
| 26 | |
| 27 | BBCLASSEXTEND = "native" |