Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images" |
| 2 | DESCRIPTION = "The gd graphics library allows your code to quickly draw images \ |
| 3 | complete with lines, arcs, text, multiple colors, cut and paste from other \ |
| 4 | images, and flood fills, and to write out the result as a PNG or JPEG file. \ |
| 5 | This is particularly useful in Web applications, where PNG and JPEG are two \ |
| 6 | of the formats accepted for inline images by most browsers. Note that gd is not \ |
| 7 | a paint program." |
| 8 | HOMEPAGE = "http://libgd.github.io/" |
| 9 | |
| 10 | SECTION = "libs" |
| 11 | LICENSE = "GD" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=ace63adfdac78400fc30fa22ee9c1bb1" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS = "freetype libpng jpeg zlib tiff" |
| 15 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | SRC_URI = "git://github.com/libgd/libgd.git;nobranch=1;protocol=https \ |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 17 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 19 | SRCREV = "b5319a41286107b53daa0e08e402aa1819764bdc" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit autotools binconfig gettext pkgconfig |
| 24 | |
| 25 | EXTRA_OECONF += " --disable-rpath \ |
| 26 | --with-jpeg=${STAGING_LIBDIR}/.. \ |
| 27 | --with-freetype=yes \ |
| 28 | --without-fontconfig \ |
| 29 | --without-webp \ |
| 30 | --without-xpm \ |
| 31 | --without-x \ |
| 32 | " |
| 33 | |
| 34 | EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"' |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | do_install:append:class-target() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | # cleanup buildpaths from gdlib.pc |
| 40 | sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc |
| 41 | } |
| 42 | |
| 43 | PACKAGES += "${PN}-tools" |
| 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | FILES:${PN} = "${libdir}/lib*${SOLIBS}" |
| 46 | FILES:${PN}-tools = "${bindir}/*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 47 | |
| 48 | PROVIDES += "${PN}-tools" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | RPROVIDES:${PN}-tools = "${PN}-tools" |
| 50 | RDEPENDS:${PN}-tools = "perl perl-module-strict" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 51 | |
| 52 | CVE_PRODUCT = "libgd" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 53 | |
| 54 | BBCLASSEXTEND = "native nativesdk" |