| SUMMARY = "Extensible memoizing collections and decorators" |
| HOMEPAGE = "https://github.com/tkem/cachetools" |
| DESCRIPTION = "This module provides various memoizing \ |
| collections and decorators, including variants of the \ |
| Python 3 Standard Library @lru_cache function decorator." |
| SECTION = "devel/python" |
| |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362" |
| |
| inherit pypi setuptools3 ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS_${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |
| |
| SRC_URI[md5sum] = "ae41b69896f49727e1621d279cb72522" |
| SRC_URI[sha256sum] = "bbaa39c3dede00175df2dc2b03d0cf18dd2d32a7de7beb68072d13043c9edb20" |
| |
| BBCLASSEXTEND = "native nativesdk" |