| SUMMARY = "Extensible memoizing collections and decorators" |
| HOMEPAGE = "https://github.com/tkem/cachetools" |
| DESCRIPTION = "This module provides various memoizing \ |
| collections and decorators, including variants of the \ |
| Python 3 Standard Library @lru_cache function decorator." |
| SECTION = "devel/python" |
| |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=439a07e400525964c3c82684146e46eb" |
| |
| inherit pypi setuptools3 ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN} += " \ |
| ${PYTHON_PN}-math \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |
| |
| SRC_URI[sha256sum] = "61b5ed1e22a0924aed1d23b478f37e8d52549ff8a961de2909c69bf950020cff" |
| |
| BBCLASSEXTEND = "native nativesdk" |