| SUMMARY = "Inspect and manipulate eBPF programs and maps" |
| DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \ |
| of eBPF programs and maps." |
| DEPENDS = "binutils elfutils" |
| PROVIDES = "virtual/bpftool" |
| inherit bash-completion kernelsrc kernel-arch |
| do_populate_lic[depends] += "virtual/kernel:do_patch" |
| -C ${S}/tools/bpf/bpftool \ |
| CC="${CC} ${DEBUG_PREFIX_MAP} -fdebug-prefix-map=${STAGING_KERNEL_DIR}=${KERNEL_SRC_PATH}" \ |
| do_configure[depends] += "virtual/kernel:do_shared_workdir" |
| COMPATIBLE_HOST = "(x86_64).*-linux" |
| COMPATIBLE_HOST:libc-musl = 'null' |
| oe_runmake DESTDIR=${D} install |
| PACKAGE_ARCH = "${MACHINE_ARCH}" |
| python do_package:prepend() { |
| d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
| B = "${WORKDIR}/${BPN}-${PV}" |