| SUMMARY = "Software Construction tool (make/autotools replacement)" |
| SECTION = "devel/python" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=37bb53a08e6beaea0c90e7821d731284" |
| |
| SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz" |
| SRC_URI[md5sum] = "e2fe9d16f81b0285b969238af4b552ff" |
| SRC_URI[sha256sum] = "f3f548d738d4a2179123ecd744271ec413b2d55735ea7625a59b1b59e6cd132f" |
| |
| S = "${WORKDIR}/scons-${PV}" |
| |
| UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html" |
| UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" |
| |
| inherit setuptools3 |
| |
| do_install_prepend() { |
| sed -i -e "1s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/script/* |
| } |
| |
| RDEPENDS_${PN} = "\ |
| python3-core \ |
| python3-fcntl \ |
| python3-io \ |
| python3-json \ |
| python3-shell \ |
| python3-pickle \ |
| python3-pprint \ |
| " |