| SUMMARY = "OpenPOWER Debug Collector" |
| DESCRIPTION = "Application to log error during host checkstop and watchdog timeout" |
| inherit pkgconfig meson \ |
| require ${BPN}-systemd-links.inc |
| ${PYTHON_PN}-sdbus++-native \ |
| # This provides below applications that are called into in case |
| # of host checkstop, host watchdog and host watchdog-timeout respectively. |
| ${@bb.utils.contains('MACHINE_FEATURES', 'phal', '', 'watchdog-timeout', d)} \ |
| DEBUG_TMPL = "openpower-debug-collector-{0}@.service" |
| SYSTEMD_SERVICE:${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}" |
| # Do not depend on phosphor-logging for native build |
| DEPENDS:remove:class-native = "phosphor-logging" |
| # Do not depend on phosphor-logging for native SDK build |
| DEPENDS:remove:class-nativesdk = "phosphor-logging ipl" |