| SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed." |
| DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \ |
| By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \ |
| polling, WebSockets, and other applications that require a long-lived connection to each user." |
| HOMEPAGE = "http://www.tornadoweb.org/en/stable/" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| |
| SRC_URI[sha256sum] = "d68f3192936ff2c4add04dc21a436a43b4408d466746b78bb2b9d0a53a18683f" |
| |
| inherit pypi setuptools3 |
| |
| # Requires _compression which is currently located in misc |
| RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \ |
| ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \ |
| ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc" |
| |
| RDEPENDS:${PN}-test += "${PN} ${PYTHON_PN}-unittest" |
| |
| PACKAGES =+ "\ |
| ${PN}-test \ |
| " |
| |
| FILES:${PN}-test = " \ |
| ${libdir}/${PYTHON_DIR}/site-packages/*/test \ |
| ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \ |
| " |