| SUMMARY = "Python GObject bindings" |
| HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject" |
| DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more." |
| SECTION = "devel/python" |
| LICENSE = "LGPLv2.1" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| |
| GNOMEBASEBUILDCLASS = "meson" |
| inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even |
| |
| DEPENDS += "python3 glib-2.0" |
| |
| SRCNAME="pygobject" |
| |
| SRC_URI = " \ |
| http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| file://0001-Do-not-build-tests.patch \ |
| " |
| SRC_URI[sha256sum] = "0372d1bb9122fc19f500a249b1f38c2bb67485000f5887497b4b205b3e7084d5" |
| |
| UNKNOWN_CONFIGURE_WHITELIST = "introspection" |
| |
| S = "${WORKDIR}/${SRCNAME}-${PV}" |
| |
| PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| |
| RDEPENDS_${PN} += "python3-pkgutil" |
| |
| # python3-pycairo is checked on configuration -> DEPENDS |
| # we don't link against python3-pycairo -> RDEPENDS |
| PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo" |
| |
| BBCLASSEXTEND = "native" |
| PACKAGECONFIG_class-native = "" |