| SUMMARY = "Modern password hashing for your software and your servers." |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c" |
| HOMEPAGE = "https://pypi.org/project/bcrypt/" |
| |
| DEPENDS += "${PYTHON_PN}-cffi-native" |
| |
| SRC_URI[sha256sum] = "27d375903ac8261cfe4047f6709d16f7d18d39b1ec92aaf72af989552a650ebd" |
| |
| inherit pypi python_setuptools3_rust ptest-cargo cargo-update-recipe-crates |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| CARGO_SRC_DIR = "src/_bcrypt" |
| |
| require ${BPN}-crates.inc |
| |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| ${PYTHON_PN}-unittest-automake-output \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |
| |
| RDEPENDS:${PN}:class-target += "\ |
| ${PYTHON_PN}-cffi \ |
| ${PYTHON_PN}-ctypes \ |
| ${PYTHON_PN}-shell \ |
| ${PYTHON_PN}-six \ |
| " |