| require icu.inc |
| |
| LIC_FILES_CHKSUM = "file://../LICENSE;md5=63752c57bd0b365c9af9f427ef79c819" |
| |
| def icu_download_version(d): |
| pvsplit = d.getVar('PV').split('.') |
| return pvsplit[0] + "_" + pvsplit[1] |
| |
| ICU_PV = "${@icu_download_version(d)}" |
| |
| # http://errors.yoctoproject.org/Errors/Details/20486/ |
| ARM_INSTRUCTION_SET_armv4 = "arm" |
| ARM_INSTRUCTION_SET_armv5 = "arm" |
| |
| BASE_SRC_URI = "http://download.icu-project.org/files/icu4c/${PV}/icu4c-${ICU_PV}-src.tgz" |
| SRC_URI = "${BASE_SRC_URI} \ |
| file://icu-pkgdata-large-cmd.patch \ |
| file://fix-install-manx.patch \ |
| file://0002-Add-ARC-support.patch \ |
| file://CVE-2018-18928.patch \ |
| " |
| |
| SRC_URI_append_class-target = "\ |
| file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \ |
| " |
| SRC_URI[md5sum] = "9e40f6055294284df958200e308bce50" |
| SRC_URI[sha256sum] = "05c490b69454fce5860b7e8e2821231674af0a11d7ef2febea9a32512998cb9d" |
| |
| UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)/" |
| UPSTREAM_CHECK_URI = "http://download.icu-project.org/files/icu4c/" |