| SUMMARY = "A small C library that is supposed to make it easy to run an HTTP server as part of another application" |
| HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/" |
| LICENSE = "LGPL-2.1-or-later" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36" |
| SECTION = "net" |
| |
| DEPENDS = "file" |
| |
| SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz" |
| SRC_URI[sha256sum] = "9e7023a151120060d2806a6ea4c13ca9933ece4eacfc5c9464d20edddb76b0a0" |
| |
| inherit autotools lib_package pkgconfig gettext |
| |
| CFLAGS += "-pthread -D_REENTRANT" |
| |
| EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../ --enable-largefile" |
| |
| PACKAGECONFIG ?= "curl https" |
| |
| PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," |
| PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls," |
| |
| do_compile:append() { |
| sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc |
| } |
| |
| BBCLASSEXTEND = "native nativesdk" |