fans:monitor:witherspoon: Enable JSON config
Use the installed `config.json` as the fan monitoring configuration to
load at runtime. This replaces the need of the build time YAML
`monitor.yaml` configuration.
Tested:
`monitor.yaml` removed from build image staging location
Built/powered on image using the `config.json` file
(From meta-ibm rev: 27be42e03193352d7c7ee51784448cb06d1b8e2c)
Change-Id: I80c268b26dddd820e7c9c640eab2d39452ab3a29
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
index 9307f17..cb29a74 100644
--- a/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
+++ b/meta-ibm/recipes-phosphor/fans/phosphor-fan-monitor-config.bbappend
@@ -1,14 +1,11 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
-SRC_URI_witherspoon += "file://monitor.yaml"
-SRC_URI_witherspoon += "file://config.json"
+SRC_URI_witherspoon = "file://config.json"
-do_install_append_witherspoon() {
- DEST=${D}${monitor_datadir}
- install -D monitor.yaml ${D}${monitor_datadir}/monitor.yaml
+do_install_witherspoon() {
install -d ${D}/${datadir}/phosphor-fan-presence/monitor/
install -m 0644 ${WORKDIR}/config.json ${D}/${datadir}/phosphor-fan-presence/monitor/
}
-FILES_${PN}_witherspoon += "${datadir}/phosphor-fan-presence/monitor/config.json"
-FILES_${PN}_witherspoon += "${monitor_datadir}/monitor.yaml"
+FILES_${PN}_append_witherspoon = " ${datadir}/phosphor-fan-presence/monitor/config.json"
+FILES_${PN}_remove_witherspoon = "${monitor_datadir}/monitor.yaml"