blob: 4936dcfd3a7a6fdc5e51b98db35a465e7d1993e7 [file] [log] [blame]
SUMMARY = "U-boot boot scripts for Raspberry Pi"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
COMPATIBLE_MACHINE = "rpi"
DEPENDS = "u-boot-mkimage-native"
SRC_URI = "file://boot.cmd"
do_compile() {
mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
}
inherit deploy
do_deploy() {
install -d ${DEPLOYDIR}
install -m 0644 boot.scr ${DEPLOYDIR}
}
addtask do_deploy after do_compile before do_build