| SUMMARY = "Startup script and systemd unit file for the Weston Wayland compositor" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| |
| SRC_URI = "file://init \ |
| file://weston.service \ |
| file://weston-start" |
| |
| S = "${WORKDIR}" |
| |
| do_install() { |
| install -Dm755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/weston |
| install -Dm0644 ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service |
| |
| # Install weston-start script |
| install -Dm755 ${WORKDIR}/weston-start ${D}${bindir}/weston-start |
| sed -i 's,@DATADIR@,${datadir},g' ${D}${bindir}/weston-start |
| sed -i 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${bindir}/weston-start |
| } |
| |
| inherit allarch update-rc.d distro_features_check systemd |
| |
| # rdepends on weston which depends on virtual/egl |
| REQUIRED_DISTRO_FEATURES = "opengl" |
| |
| RDEPENDS_${PN} = "weston kbd" |
| |
| INITSCRIPT_NAME = "weston" |
| INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ." |
| |
| SYSTEMD_SERVICE_${PN} = "weston.service" |