| SUMMARY = "A complete, cross-platform solution to record, convert and stream audio and video." |
| DESCRIPTION = "FFmpeg is the leading multimedia framework, able to decode, encode, transcode, \ |
| mux, demux, stream, filter and play pretty much anything that humans and machines \ |
| have created. It supports the most obscure ancient formats up to the cutting edge." |
| HOMEPAGE = "https://www.ffmpeg.org/" |
| SECTION = "libs" |
| |
| LICENSE = "BSD & GPLv2+ & LGPLv2.1+ & MIT" |
| LICENSE_${PN} = "GPLv2+" |
| LICENSE_libavcodec = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_libavdevice = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_libavfilter = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_libavformat = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_libavresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_libavutil = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_libpostproc = "GPLv2+" |
| LICENSE_libswresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_libswscale = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}" |
| LICENSE_FLAGS = "commercial" |
| |
| LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ |
| file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \ |
| file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02" |
| |
| SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz \ |
| file://mips64_cpu_detection.patch \ |
| file://0001-lavf-srt-fix-build-fail-when-used-the-libsrt-1.4.1.patch \ |
| file://0001-libavutil-include-assembly-with-full-path-from-sourc.patch \ |
| file://CVE-2020-35964.patch \ |
| file://CVE-2020-35965.patch \ |
| " |
| SRC_URI[sha256sum] = "ad009240d46e307b4e03a213a0f49c11b650e445b1f8be0dda2a9212b34d2ffb" |
| |
| # Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717 |
| ARM_INSTRUCTION_SET_armv4 = "arm" |
| ARM_INSTRUCTION_SET_armv5 = "arm" |
| ARM_INSTRUCTION_SET_armv6 = "arm" |
| |
| # Should be API compatible with libav (which was a fork of ffmpeg) |
| # libpostproc was previously packaged from a separate recipe |
| PROVIDES = "libav libpostproc" |
| |
| DEPENDS = "nasm-native" |
| |
| inherit autotools pkgconfig |
| |
| PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc avresample \ |
| alsa bzlib gpl lzma pic pthreads shared theora x264 zlib \ |
| ${@bb.utils.contains('AVAILTUNES', 'mips32r2', 'mips32r2', '', d)} \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xv xcb', '', d)}" |
| |
| # libraries to build in addition to avutil |
| PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice" |
| PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter" |
| PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec" |
| PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat" |
| PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample" |
| PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale" |
| PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc" |
| PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample" |
| |
| # features to support |
| PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" |
| PACKAGECONFIG[altivec] = "--enable-altivec,--disable-altivec," |
| PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2" |
| PACKAGECONFIG[fdk-aac] = "--enable-libfdk-aac --enable-nonfree,--disable-libfdk-aac,fdk-aac" |
| PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl" |
| PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm" |
| PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack" |
| PACKAGECONFIG[libvorbis] = "--enable-libvorbis,--disable-libvorbis,libvorbis" |
| PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz" |
| PACKAGECONFIG[mfx] = "--enable-libmfx,--disable-libmfx,intel-mediasdk" |
| PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame" |
| PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| PACKAGECONFIG[sdl2] = "--enable-sdl2,--disable-sdl2,virtual/libsdl2" |
| PACKAGECONFIG[speex] = "--enable-libspeex,--disable-libspeex,speex" |
| PACKAGECONFIG[srt] = "--enable-libsrt,--disable-libsrt,srt" |
| PACKAGECONFIG[theora] = "--enable-libtheora,--disable-libtheora,libtheora libogg" |
| PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva" |
| PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau" |
| PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx" |
| PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264" |
| PACKAGECONFIG[x265] = "--enable-libx265,--disable-libx265,x265" |
| PACKAGECONFIG[xcb] = "--enable-libxcb,--disable-libxcb,libxcb" |
| PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv" |
| PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib" |
| |
| # other configuration options |
| PACKAGECONFIG[mips32r2] = ",--disable-mipsdsp --disable-mipsdspr2" |
| PACKAGECONFIG[pic] = "--enable-pic" |
| PACKAGECONFIG[pthreads] = "--enable-pthreads,--disable-pthreads" |
| PACKAGECONFIG[shared] = "--enable-shared" |
| PACKAGECONFIG[strip] = ",--disable-stripping" |
| |
| # Check codecs that require --enable-nonfree |
| USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'openssl' ], 'yes', '', d)}" |
| |
| def cpu(d): |
| for arg in (d.getVar('TUNE_CCARGS') or '').split(): |
| if arg.startswith('-mcpu='): |
| return arg[6:] |
| return 'generic' |
| |
| EXTRA_OECONF = " \ |
| ${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \ |
| \ |
| --cross-prefix=${TARGET_PREFIX} \ |
| \ |
| --ld="${CCLD}" \ |
| --cc="${CC}" \ |
| --cxx="${CXX}" \ |
| --arch=${TARGET_ARCH} \ |
| --target-os="linux" \ |
| --enable-cross-compile \ |
| --extra-cflags="${CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \ |
| --extra-ldflags="${LDFLAGS}" \ |
| --sysroot="${STAGING_DIR_TARGET}" \ |
| ${EXTRA_FFCONF} \ |
| --libdir=${libdir} \ |
| --shlibdir=${libdir} \ |
| --datadir=${datadir}/ffmpeg \ |
| --cpu=${@cpu(d)} \ |
| --pkg-config=pkg-config \ |
| " |
| |
| EXTRA_OECONF_append_linux-gnux32 = " --disable-asm" |
| # gold crashes on x86, another solution is to --disable-asm but thats more hacky |
| # ld.gold: internal error in relocate_section, at ../../gold/i386.cc:3684 |
| |
| LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
| |
| EXTRA_OEMAKE = "V=1" |
| |
| do_configure() { |
| ${S}/configure ${EXTRA_OECONF} |
| } |
| |
| # patch out build host paths for reproducibility |
| do_compile_prepend_class-target() { |
| sed -i -e "s,${WORKDIR},,g" ${B}/config.h |
| } |
| |
| PACKAGES =+ "libavcodec \ |
| libavdevice \ |
| libavfilter \ |
| libavformat \ |
| libavresample \ |
| libavutil \ |
| libpostproc \ |
| libswresample \ |
| libswscale" |
| |
| FILES_libavcodec = "${libdir}/libavcodec${SOLIBS}" |
| FILES_libavdevice = "${libdir}/libavdevice${SOLIBS}" |
| FILES_libavfilter = "${libdir}/libavfilter${SOLIBS}" |
| FILES_libavformat = "${libdir}/libavformat${SOLIBS}" |
| FILES_libavresample = "${libdir}/libavresample${SOLIBS}" |
| FILES_libavutil = "${libdir}/libavutil${SOLIBS}" |
| FILES_libpostproc = "${libdir}/libpostproc${SOLIBS}" |
| FILES_libswresample = "${libdir}/libswresample${SOLIBS}" |
| FILES_libswscale = "${libdir}/libswscale${SOLIBS}" |
| |
| # ffmpeg disables PIC on some platforms (e.g. x86-32) |
| INSANE_SKIP_${MLPREFIX}libavcodec = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavdevice = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavfilter = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavformat = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavutil = "textrel" |
| INSANE_SKIP_${MLPREFIX}libavresample = "textrel" |
| INSANE_SKIP_${MLPREFIX}libswscale = "textrel" |
| INSANE_SKIP_${MLPREFIX}libswresample = "textrel" |
| INSANE_SKIP_${MLPREFIX}libpostproc = "textrel" |