| SUMMARY = "Lightweight and flexible command-line JSON processor" |
| DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \ |
| filter and map and transform structured data with the same \ |
| ease that sed, awk, grep and friends let you play with text." |
| HOMEPAGE = "https://stedolan.github.io/jq/" |
| BUGTRACKER = "https://github.com/stedolan/jq/issues" |
| SECTION = "utils" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=2814b59e00e7918c864fa3b6bbe049b4" |
| |
| PV = "1.6+git${SRCPV}" |
| SRC_URI = "git://github.com/stedolan/jq;protocol=https;branch=master \ |
| file://0001-configure-Pass-_XOPEN_SOURCE-when-checking-for-strpt.patch \ |
| file://0002-builtin-Replace-_BSD_SOURCE-with-_DEFAULT_SOURCE.patch \ |
| file://run-ptest \ |
| " |
| SRCREV = "cff5336ec71b6fee396a95bb0e4bea365e0cd1e8" |
| S = "${WORKDIR}/git" |
| |
| inherit autotools-brokensep ptest |
| |
| PACKAGECONFIG ?= "oniguruma" |
| |
| PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native" |
| PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native" |
| PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig" |
| # enable if you want ptest running under valgrind |
| PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind" |
| |
| do_install_ptest() { |
| cp -rf ${B}/tests ${D}${PTEST_PATH} |
| cp -rf ${B}/.libs ${D}${PTEST_PATH} |
| # libjq.so.* is packaged in the main jq component, so remove it from ptest |
| rm -f ${D}${PTEST_PATH}/.libs/libjq.so.* |
| ln -sf ${bindir}/jq ${D}${PTEST_PATH} |
| if [ "${@bb.utils.contains('PACKAGECONFIG', 'valgrind', 'true', 'false', d)}" = "false" ]; then |
| sed -i 's:#export NO_VALGRIND=1:export NO_VALGRIND=1:g' ${D}${PTEST_PATH}/run-ptest |
| fi |
| # handle multilib |
| sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest |
| } |
| |
| BBCLASSEXTEND = "native" |