meta-yadro: dbus-intf: fix bootmbox interface

Since the `phosphor-dbus-interfaces` has switched to `meson` simply
adding a new YAML is not enough.

This commit appends a YAML file and few required changes in the meson
scripts to fix `xyz.openbmc_project.Control.Boot.Mailbox` interface
building.

(From meta-yadro rev: 1df817ffff7f18f435402872df1f51fa0d19f08f)

Change-Id: I211d15995f1cf6d92957b51891da1ed942ffa7b4
Signed-off-by: Alexander Filippov <a.filippov@yadro.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/meta-yadro/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend b/meta-yadro/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
index 656e151..8a5b4c3 100644
--- a/meta-yadro/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
+++ b/meta-yadro/recipes-phosphor/dbus/phosphor-dbus-interfaces_%.bbappend
@@ -1,15 +1,5 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-# Directory with new layer of source tree with additional files
-YAML_DIR = "xyz"
-
-SRC_URI += "file://${YAML_DIR}"
-
-S = "${WORKDIR}/git"
-
-# Merge source tree by original project with our layer of additional files
-do_add_yamls(){
-    cp -r "${WORKDIR}/${YAML_DIR}" "${S}"
-}
-
-addtask do_add_yamls after do_unpack before do_configure
+SRC_URI_append = "\
+    file://0001-Add-boot-initiator-mailbox-interface.patch \
+"