meta-ampere: ampere-ipmi-oem: convert cmake to meson
Change build option from cmake to meson as the ampere-ipmi-oem
repository already changed to meson build.
Tested:
- Support Get System Interface Capabilities command
- Support Clear Message Flags command
- Support IPMI Sync RTC time to BMC command
Signed-off-by: Hieu Huynh <hieuh@os.amperecomputing.com>
Change-Id: Ibf9036145069f5867849222c9925720f2c19e00f
diff --git a/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb b/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
index baeb506..55b866f 100644
--- a/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
+++ b/meta-ampere/meta-common/recipes-phosphor/ipmi/ampere-ipmi-oem.bb
@@ -6,11 +6,9 @@
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod"
+DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd"
-inherit cmake pkgconfig obmc-phosphor-ipmiprovider-symlink
-
-EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
+inherit meson pkgconfig obmc-phosphor-ipmiprovider-symlink
LIBRARY_NAMES = "libzampoemcmds.so"