blob: baeb506d1270ee5f0174d6533246a58583cbd80d [file] [log] [blame]
Hieu Huynhf3911cd2021-09-24 02:44:10 +00001SUMMARY = "Ampere OEM IPMI commands"
2DESCRIPTION = "Ampere OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5S = "${WORKDIR}"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod"
10
Thang Q. Nguyen18a6b182022-02-17 06:26:30 +000011inherit cmake pkgconfig obmc-phosphor-ipmiprovider-symlink
Hieu Huynhf3911cd2021-09-24 02:44:10 +000012
13EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
14
15LIBRARY_NAMES = "libzampoemcmds.so"
16
17S = "${WORKDIR}/git"
Patrick Williamsbb99d222022-01-24 15:55:09 -060018SRC_URI = "git://github.com/openbmc/ampere-ipmi-oem.git;branch=master;protocol=https"
Andrew Geissler6b443862022-08-05 02:30:03 -050019SRCREV = "14b2feea99509c5757404b166d23c88932768ecb"
Hieu Huynhf3911cd2021-09-24 02:44:10 +000020
21HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
22NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
23
24FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
25FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
26FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
27FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
28
29do_install:append(){
30 install -d ${D}${includedir}/ampere-ipmi-oem
31 install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/ampere-ipmi-oem
32}