Hieu Huynh | f3911cd | 2021-09-24 02:44:10 +0000 | [diff] [blame^] | 1 | SUMMARY = "Ampere OEM IPMI commands" |
| 2 | DESCRIPTION = "Ampere OEM IPMI commands" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | S = "${WORKDIR}" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd libgpiod" |
| 10 | |
| 11 | inherit cmake obmc-phosphor-ipmiprovider-symlink |
| 12 | |
| 13 | EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1" |
| 14 | |
| 15 | LIBRARY_NAMES = "libzampoemcmds.so" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | SRC_URI = "git://github.com/openbmc/ampere-ipmi-oem.git" |
| 19 | SRCREV = "1463f7013a17699081c1fbf506ee8d57827d1088" |
| 20 | |
| 21 | HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 22 | NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}" |
| 23 | |
| 24 | FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 25 | FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 26 | FILES:${PN}:append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 27 | FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}" |
| 28 | |
| 29 | do_install:append(){ |
| 30 | install -d ${D}${includedir}/ampere-ipmi-oem |
| 31 | install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/ampere-ipmi-oem |
| 32 | } |