| SUMMARY = "Crypto and TLS for C++11" |
| HOMEPAGE = "https://botan.randombit.net" |
| LICENSE = "BSD-2-Clause" |
| LIC_FILES_CHKSUM = "file://license.txt;md5=a02e03c8fa2c5e7b9b3fcc1b9811fd3b" |
| SECTION = "libs" |
| |
| SRC_URI = "https://botan.randombit.net/releases/Botan-${PV}.tar.xz" |
| SRC_URI[md5sum] = "ebc68c08b99bbc4b4fc9bdbfad398b02" |
| SRC_URI[sha256sum] = "0c10f12b424a40ee19bde00292098e201d7498535c062d8d5b586d07861a54b5" |
| |
| S = "${WORKDIR}/Botan-${PV}" |
| |
| inherit python3native siteinfo lib_package |
| |
| CPU ?= "${TARGET_ARCH}" |
| CPU_x86 = "x86_32" |
| CPU_armv7a = "armv7" |
| CPU_armv7ve = "armv7" |
| |
| do_configure() { |
| python3 ${S}/configure.py \ |
| --prefix="${D}${exec_prefix}" \ |
| --libdir="${D}${libdir}" \ |
| --cpu="${CPU}" \ |
| --cc-bin="${CXX}" \ |
| --cxxflags="${CXXFLAGS}" \ |
| --ldflags="${LDFLAGS}" \ |
| --with-endian=${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', 'little', 'big', d)} \ |
| ${@bb.utils.contains("TUNE_FEATURES","neon","","--disable-neon",d)} \ |
| --with-sysroot-dir=${STAGING_DIR_HOST} \ |
| --with-build-dir="${B}" \ |
| --optimize-for-size \ |
| --with-stack-protector \ |
| --enable-shared-library \ |
| --with-python-versions=3 \ |
| ${EXTRA_OECONF} |
| } |
| |
| do_compile() { |
| oe_runmake |
| } |
| do_install() { |
| oe_runmake install |
| sed -i -e "s|${D}||g" ${D}${libdir}/pkgconfig/botan-2.pc |
| } |
| |
| PACKAGES += "${PN}-python3" |
| |
| FILES_${PN}-python3 = "${libdir}/python3" |
| |
| RDEPENDS_${PN}-python3 += "python3" |