| SUMMARY = "Accessibility toolkit for GNOME" |
| HOMEPAGE = "http://live.gnome.org/GAP/" |
| BUGTRACKER = "https://bugzilla.gnome.org/" |
| SECTION = "x11/libs" |
| |
| LICENSE = "GPLv2+ & LGPLv2+" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \ |
| file://atk/atkutil.c;endline=18;md5=6fd31cd2fdc9b30f619ca8d819bc12d3 \ |
| file://atk/atk.h;endline=18;md5=fcd7710187e0eae485e356c30d1b0c3b" |
| |
| # Need gettext-native as Meson can't turn off i18n |
| DEPENDS = "gettext-native glib-2.0" |
| |
| GNOMEBASEBUILDCLASS = "meson" |
| inherit gnomebase gtk-doc gettext upstream-version-is-even gobject-introspection |
| |
| GTKDOC_ENABLE_FLAG = "-Denable_docs=true" |
| GTKDOC_DISABLE_FLAG = "-Denable_docs=false" |
| |
| GI_ENABLE_FLAG = "-Ddisable_introspection=false" |
| GI_DISABLE_FLAG = "-Ddisable_introspection=true" |
| |
| EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \ |
| '${GI_DISABLE_FLAG}', d)} " |
| |
| EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \ |
| '${GTKDOC_DISABLE_FLAG}', d)} " |
| |
| SRC_URI_append = " \ |
| file://0001-meson.build-enable-introspection-for-cross-compile.patch \ |
| file://0001-Switch-from-filename-to-basename.patch \ |
| " |
| SRC_URI[archive.md5sum] = "dfb5e7474220afa3f4ca7e45af9f3a11" |
| SRC_URI[archive.sha256sum] = "cd3a1ea6ecc268a2497f0cd018e970860de24a6d42086919d6bf6c8e8d53f4fc" |
| |
| BBCLASSEXTEND = "native" |
| |