| SUMMARY = "A complete, cross-platform solution to record, convert and stream audio and video." |
| DESCRIPTION = "FFmpeg is the leading multimedia framework, able to decode, encode, transcode, \ |
| mux, demux, stream, filter and play pretty much anything that humans and machines \ |
| have created. It supports the most obscure ancient formats up to the cutting edge." |
| HOMEPAGE = "https://www.ffmpeg.org/" |
| SECTION = "libs" |
| |
| LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later & ISC & MIT & BSD-2-Clause & BSD-3-Clause & IJG" |
| LICENSE:${PN} = "GPL-2.0-or-later" |
| LICENSE:libavcodec = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPL-2.0-or-later', 'LGPL-2.1-or-later', d)}" |
| LICENSE:libavdevice = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPL-2.0-or-later', 'LGPL-2.1-or-later', d)}" |
| LICENSE:libavfilter = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPL-2.0-or-later', 'LGPL-2.1-or-later', d)}" |
| LICENSE:libavformat = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPL-2.0-or-later', 'LGPL-2.1-or-later', d)}" |
| LICENSE:libavutil = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPL-2.0-or-later', 'LGPL-2.1-or-later', d)}" |
| LICENSE:libpostproc = "GPL-2.0-or-later" |
| LICENSE:libswresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPL-2.0-or-later', 'LGPL-2.1-or-later', d)}" |
| LICENSE:libswscale = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPL-2.0-or-later', 'LGPL-2.1-or-later', d)}" |
| LICENSE_FLAGS = "commercial" |
| |
| LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ |
| file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \ |
| file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02" |
| |
| # Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717 |
| ARM_INSTRUCTION_SET_armv4 = "arm" |
| ARM_INSTRUCTION_SET_armv5 = "arm" |
| ARM_INSTRUCTION_SET_armv6 = "arm" |
| # Should be API compatible with libav (which was a fork of ffmpeg) |
| # libpostproc was previously packaged from a separate recipe |
| PROVIDES = "ffmpeg libav libpostproc" |
| RPROVIDES:${PN} = "${PROVIDES}" |
| DEPENDS = "nasm-native" |
| |
| inherit autotools pkgconfig |
| PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc avresample \ |
| opengl udev sdl2 ffplay alsa bzlib lzma pic pthreads shared theora zlib \ |
| libvorbis x264 gpl sand rpi vout-drm vout-egl \ |
| ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'mmal', d)} \ |
| ${@bb.utils.contains('AVAILTUNES', 'mips32r2', 'mips32r2', '', d)} \ |
| ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xv xcb', '', d)}" |
| |
| SRC_URI = "\ |
| git://git@github.com/RPi-Distro/ffmpeg;protocol=https;branch=pios/bullseye \ |
| file://0001-avcodec-arm-sbcenc-avoid-callee-preserved-vfp-regist.patch \ |
| file://0002-Fix-build-on-powerpc-and-ppc64.patch \ |
| file://0003-avcodec-pngenc-remove-monowhite-from-apng-formats.patch \ |
| file://0004-ffmpeg-4.3.2-rpi_10.patch \ |
| file://0005-fix_flags.diff \ |
| " |
| |
| SRCREV = "ea72093f350f38edcd39c480b331c3219c377642" |
| |
| S = "${WORKDIR}/git" |
| |
| # libraries to build in addition to avutil |
| PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice" |
| PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter" |
| PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec" |
| PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat" |
| PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample" |
| PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale" |
| PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc" |
| PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample" |
| |
| # features to support |
| PACKAGECONFIG[ffplay] = "--enable-ffplay,--disable-ffplay" |
| PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" |
| PACKAGECONFIG[altivec] = "--enable-altivec,--disable-altivec," |
| PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2" |
| PACKAGECONFIG[fdk-aac] = "--enable-libfdk-aac --enable-nonfree,--disable-libfdk-aac,fdk-aac" |
| PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl" |
| PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl" |
| PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm" |
| PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack" |
| PACKAGECONFIG[libvorbis] = "--enable-libvorbis,--disable-libvorbis,libvorbis" |
| PACKAGECONFIG[libopus] = "--enable-libopus,--disable-libopus,libopus" |
| PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz" |
| PACKAGECONFIG[mfx] = "--enable-libmfx,--disable-libmfx,intel-mediasdk" |
| PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame" |
| PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| PACKAGECONFIG[sdl2] = "--enable-sdl2,--disable-sdl2,virtual/libsdl2" |
| PACKAGECONFIG[speex] = "--enable-libspeex,--disable-libspeex,speex" |
| PACKAGECONFIG[srt] = "--enable-libsrt,--disable-libsrt,srt" |
| PACKAGECONFIG[theora] = "--enable-libtheora,--disable-libtheora,libtheora libogg" |
| PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva" |
| PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau" |
| PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx" |
| PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264" |
| PACKAGECONFIG[xcb] = "--enable-libxcb,--disable-libxcb,libxcb" |
| PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv" |
| PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib" |
| #PACKAGECONFIG[snappy] = "--enable-libsnappy,--enable-libsnappy,snappy" |
| PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev" |
| PACKAGECONFIG[v4l2] = "--enable-libv4l2 --enable-v4l2-request --enable-libdrm,,v4l-utils" |
| PACKAGECONFIG[mmal] = "--enable-omx --enable-omx-rpi --enable-mmal,,userland" |
| PACKAGECONFIG[sand] = "--enable-sand,," |
| PACKAGECONFIG[rpi] = "--enable-rpi,," |
| PACKAGECONFIG[vout-drm] = "--enable-vout-drm,,libdrm" |
| PACKAGECONFIG[vout-egl] = "--enable-vout-egl,,virtual/egl" |
| |
| # other configuration options |
| PACKAGECONFIG[mips32r2] = ",--disable-mipsdsp --disable-mipsdspr2" |
| PACKAGECONFIG[pic] = "--enable-pic" |
| PACKAGECONFIG[pthreads] = "--enable-pthreads,--disable-pthreads" |
| PACKAGECONFIG[shared] = "--enable-shared" |
| PACKAGECONFIG[strip] = ",--disable-stripping" |
| |
| # Check codecs that require --enable-nonfree |
| USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'openssl' ], 'yes', '', d)}" |
| |
| def cpu(d): |
| for arg in (d.getVar('TUNE_CCARGS') or '').split(): |
| if arg.startswith('-mcpu='): |
| return arg[6:] |
| return 'generic' |
| |
| EXTRA_OECONF = " \ |
| ${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \ |
| \ |
| --cross-prefix=${TARGET_PREFIX} \ |
| \ |
| --ld="${CCLD}" \ |
| --cc="${CC}" \ |
| --cxx="${CXX}" \ |
| --arch=${TARGET_ARCH} \ |
| --target-os="linux" \ |
| --enable-cross-compile \ |
| --extra-cflags="${CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \ |
| --extra-ldflags="${LDFLAGS}" \ |
| --sysroot="${STAGING_DIR_TARGET}" \ |
| ${EXTRA_FFCONF} \ |
| --libdir=${libdir} \ |
| --shlibdir=${libdir} \ |
| --datadir=${datadir}/ffmpeg \ |
| --cpu=${@cpu(d)} \ |
| --pkg-config=pkg-config \ |
| " |
| EXTRA_OECONF:append:linux-gnux32 = " --disable-asm" |
| |
| # Directly specify the include directories the contain headers for |
| # libdrm |
| # openmaxil |
| TARGET_CFLAGS:append = " -I${STAGING_INCDIR}/IL -I${STAGING_INCDIR}/drm" |
| |
| # gold crashes on x86, another solution is to --disable-asm but thats more hacky |
| # ld.gold: internal error in relocate_section, at ../../gold/i386.cc:3684 |
| LDFLAGS:append:x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
| EXTRA_OEMAKE = "V=1" |
| |
| do_configure() { |
| ${S}/configure ${EXTRA_OECONF} |
| } |
| |
| # patch out build host paths for reproducibility |
| do_compile:prepend:class-target() { |
| sed -i -e "s,${WORKDIR},,g" ${B}/config.h |
| } |
| |
| PACKAGES =+ "libavcodec \ |
| libavdevice \ |
| libavfilter \ |
| libavformat \ |
| libavresample \ |
| libavutil \ |
| libpostproc \ |
| libswresample \ |
| libswscale" |
| |
| FILES:${PN}:append = " /usr/share/ffmpeg" |
| FILES:libavcodec = "${libdir}/libavcodec${SOLIBS}" |
| FILES:libavdevice = "${libdir}/libavdevice${SOLIBS}" |
| FILES:libavfilter = "${libdir}/libavfilter${SOLIBS}" |
| FILES:libavformat = "${libdir}/libavformat${SOLIBS}" |
| FILES:libavresample = "${libdir}/libavresample${SOLIBS}" |
| FILES:libavutil = "${libdir}/libavutil${SOLIBS}" |
| FILES:libpostproc = "${libdir}/libpostproc${SOLIBS}" |
| FILES:libswresample = "${libdir}/libswresample${SOLIBS}" |
| FILES:libswscale = "${libdir}/libswscale${SOLIBS}" |
| # ffmpeg disables PIC on some platforms (e.g. x86-32) |
| INSANE_SKIP:${MLPREFIX}libavcodec = "textrel" |
| INSANE_SKIP:${MLPREFIX}libavdevice = "textrel" |
| INSANE_SKIP:${MLPREFIX}libavfilter = "textrel" |
| INSANE_SKIP:${MLPREFIX}libavformat = "textrel" |
| INSANE_SKIP:${MLPREFIX}libavutil = "textrel" |
| INSANE_SKIP:${MLPREFIX}libavresample = "textrel" |
| INSANE_SKIP:${MLPREFIX}libswscale = "textrel" |
| INSANE_SKIP:${MLPREFIX}libswresample = "textrel" |
| INSANE_SKIP:${MLPREFIX}libpostproc = "textrel" |
| |
| # Only enable it for rpi class of machines |
| COMPATIBLE_HOST = "null" |
| COMPATIBLE_HOST:rpi = "'(.*)'" |
| |