| SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet." |
| SECTION = "devel/python" |
| LICENSE = "BSD-2-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3a9dab7f159514231249aa3e108ab26b" |
| |
| DEPENDS += "python3-setuptools-scm-native" |
| |
| SRC_URI[sha256sum] = "c3f9e322b1ebeebd44e3d9d2d9b124e0c550c1ef41bd552afdcdd719516ee41a" |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| inherit pypi python_setuptools_build_meta ptest |
| |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |