SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet." | |
SECTION = "devel/python" | |
LICENSE = "BSD-2-Clause" | |
LIC_FILES_CHKSUM = "file://LICENSE;md5=3a9dab7f159514231249aa3e108ab26b" | |
DEPENDS += "python3-setuptools-scm-native" | |
SRC_URI[sha256sum] = "0379d6cf1ff987cd421609a264ce025e74f346e3e145dd106c0cc2e3ec3f99a9" | |
SRC_URI += " \ | |
file://run-ptest \ | |
" | |
inherit pypi python_setuptools_build_meta ptest | |
RDEPENDS:${PN}-ptest += " \ | |
${PYTHON_PN}-pytest \ | |
" | |
do_install_ptest() { | |
install -d ${D}${PTEST_PATH}/tests | |
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | |
} |