| SUMMARY = "Lightweight crypto and SSL/TLS library" |
| DESCRIPTION = "mbedtls is a lean open source crypto library \ |
| for providing SSL and TLS support in your programs. It offers \ |
| an intuitive API and documented header files, so you can actually \ |
| understand what the code does. It features: \ |
| \ |
| - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \ |
| Camellia and XTEA \ |
| - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \ |
| - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \ |
| - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \ |
| ECDSA and ECDH \ |
| - SSL v3 and TLS 1.0, 1.1 and 1.2 \ |
| - Abstraction layers for ciphers, hashes, public key operations, \ |
| platform abstraction and threading \ |
| " |
| |
| HOMEPAGE = "https://tls.mbed.org/" |
| |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| |
| SECTION = "libs" |
| |
| S = "${WORKDIR}/git" |
| SRCREV = "e483a77c85e1f9c1dd2eb1c5a8f552d2617fe400" |
| SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=development" |
| SRC_URI += "file://0001-ssl_tls-Increase-size-of-padbuf-to-64.patch" |
| |
| inherit cmake |
| |
| PACKAGECONFIG ??= "shared-libs programs" |
| PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF" |
| PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF" |
| PACKAGECONFIG[werror] = "-DMBEDTLS_FATAL_WARNINGS=ON,-DMBEDTLS_FATAL_WARNINGS=OFF" |
| |
| EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}" |
| |
| PROVIDES += "polarssl" |
| RPROVIDES_${PN} = "polarssl" |
| |
| PACKAGES =+ "${PN}-programs" |
| FILES_${PN}-programs = "${bindir}/" |
| |
| BBCLASSEXTEND = "native nativesdk" |