| # SPDX-FileCopyrightText: Huawei Inc. |
| # |
| # SPDX-License-Identifier: MIT |
| |
| HOMEPAGE = "https://lvgl.io/" |
| DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI" |
| SUMMARY = "Light and Versatile Graphics Library" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a" |
| |
| SRC_URI = "\ |
| git://github.com/lvgl/lvgl;protocol=https;branch=master \ |
| file://0002-fix-sdl-handle-both-LV_IMAGE_SRC_FILE-and-LV_IMAGE_S.patch \ |
| file://0007-fix-cmake-generate-versioned-shared-libraries.patch \ |
| file://0008-fix-fbdev-set-resolution-prior-to-buffer.patch \ |
| " |
| SRCREV = "e1c0b21b2723d391b885de4b2ee5cc997eccca91" |
| |
| inherit cmake |
| |
| EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${baselib} -DBUILD_SHARED_LIBS=ON" |
| S = "${WORKDIR}/git" |
| |
| require lv-conf.inc |
| |
| do_install:append() { |
| install -d "${D}${includedir}/${PN}" |
| install -m 0644 "${S}/lv_conf.h" "${D}${includedir}/${PN}/lv_conf.h" |
| } |
| |
| FILES:${PN}-dev += "\ |
| ${includedir}/${PN}/ \ |
| " |