| SUMMARY = "Tools to manipulate UEFI variables" |
| DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility" |
| HOMEPAGE = "https://github.com/rhboot/efivar" |
| |
| LICENSE = "LGPL-2.1-or-later" |
| LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393" |
| |
| COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| |
| SRC_URI = "git://github.com/rhinstaller/efivar.git;branch=main;protocol=https \ |
| file://0001-docs-do-not-build-efisecdb-manpage.patch \ |
| " |
| SRCREV = "90e88b221e8bc60dc50f3246051369b8f580c0d0" |
| PV .= "+39+git" |
| |
| S = "${WORKDIR}/git" |
| |
| inherit pkgconfig |
| |
| export CCLD_FOR_BUILD = "${BUILD_CCLD}" |
| |
| do_compile() { |
| oe_runmake ERRORS= HOST_CFLAGS="${BUILD_CFLAGS}" HOST_LDFLAGS="${BUILD_LDFLAGS}" |
| } |
| |
| do_install() { |
| oe_runmake install DESTDIR=${D} |
| } |
| |
| BBCLASSEXTEND = "native" |
| |
| RRECOMMENDS:${PN}:class-target = "kernel-module-efivarfs" |
| |
| CLEANBROKEN = "1" |