| SUMMARY = "A collection of ASN.1-based protocols modules." |
| DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\ |
| classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\ |
| data structures (X.509, PKCS etc.)." |
| HOMEPAGE = "https://github.com/etingof/pyasn1-modules" |
| LICENSE = "BSD-2-Clause" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=190f79253908c986e6cacf380c3a5f6d" |
| |
| SRC_URI[sha256sum] = "831dbcea1b177b28c9baddf4c6d1013c24c3accd14a1873fffaa6a2e905f17b6" |
| |
| PYPI_PACKAGE = "pyasn1_modules" |
| |
| inherit pypi ptest setuptools3 |
| |
| RDEPENDS:${PN} = "python3-pyasn1" |
| |
| BBCLASSEXTEND = "native nativesdk" |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| python3-pytest \ |
| python3-unittest-automake-output \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |