| SUMMARY = "Style preserving TOML library" |
| HOMEPAGE = "https://pypi.org/project/tomlkit/" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82" |
| |
| SRC_URI[sha256sum] = "75baf5012d06501f07bee5bf8e801b9f343e7aac5a92581f20f80ce632e6b5a4" |
| |
| inherit pypi python_poetry_core ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN} += " \ |
| python3-datetime \ |
| python3-profile \ |
| python3-stringold \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| python3-poetry-core \ |
| python3-pytest \ |
| python3-pyyaml \ |
| python3-unittest-automake-output \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |
| |
| BBCLASSEXTEND = "native nativesdk" |