| SUMMARY = "Makes working with XML feel like you are working with JSON" |
| AUTHOR = "Martin Blech" |
| HOMEPAGE = "https://github.com/martinblech/xmltodict" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2" |
| |
| SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56" |
| |
| PYPI_PACKAGE = "xmltodict" |
| |
| inherit pypi setuptools3 ptest |
| |
| SRC_URI += " \ |
| file://run-ptest \ |
| " |
| |
| RDEPENDS:${PN} += " \ |
| ${PYTHON_PN}-core \ |
| ${PYTHON_PN}-xml \ |
| ${PYTHON_PN}-io \ |
| " |
| |
| RDEPENDS:${PN}-ptest += " \ |
| ${PYTHON_PN}-pytest \ |
| " |
| |
| do_install_ptest() { |
| install -d ${D}${PTEST_PATH}/tests |
| cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| } |