| SUMMARY = "The PyPA recommended tool for installing Python packages" |
| HOMEPAGE = "https://pypi.python.org/pypi/pip" |
| SECTION = "devel/python" |
| LICENSE = "MIT" |
| LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e" |
| |
| DEPENDS += "python3 python3-setuptools-native" |
| |
| SRC_URI[md5sum] = "f417444c66a0db1a82c8d9d2283a2f95" |
| SRC_URI[sha256sum] = "e7a31f147974362e6c82d84b91c7f2bdf57e4d3163d3d454e6c3e71944d67135" |
| |
| inherit pypi distutils3 |
| |
| do_install_append() { |
| # Install as pip3 and leave pip2 as default |
| rm ${D}/${bindir}/pip |
| } |
| |
| RDEPENDS_${PN} = "\ |
| python3-compile \ |
| python3-io \ |
| python3-html \ |
| python3-json \ |
| python3-netserver \ |
| python3-setuptools \ |
| python3-unixadmin \ |
| python3-xmlrpc \ |
| python3-pickle \ |
| " |
| |
| BBCLASSEXTEND = "native nativesdk" |